summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Dale <richard.dale@codethink.co.uk>2015-06-17 13:07:23 +0100
committerRichard Dale <richard.dale@codethink.co.uk>2015-06-17 13:07:23 +0100
commite6d1a21591a05e2218004993f60933e65a6820e3 (patch)
treebc8e16a5e0e46c27f2023a3c5ba3fada9a6e312a
parent0661092185028a9efde481929b6e912220df3c99 (diff)
downloaddefinitions-e6d1a21591a05e2218004993f60933e65a6820e3.tar.gz
Remove over-complicated sed commands, use latest rpcd and netifd
-rw-r--r--strata/cpe-wrt.morph4
-rw-r--r--strata/cpe-wrt/netifd.morph7
-rw-r--r--strata/cpe-wrt/procd.morph1
-rw-r--r--strata/cpe-wrt/rpcd.morph3
4 files changed, 2 insertions, 13 deletions
diff --git a/strata/cpe-wrt.morph b/strata/cpe-wrt.morph
index 3b5df665..1780aed5 100644
--- a/strata/cpe-wrt.morph
+++ b/strata/cpe-wrt.morph
@@ -136,7 +136,7 @@ chunks:
- name: netifd
morph: strata/cpe-wrt/netifd.morph
repo: upstream:openwrt/netifd
- ref: 4d84111e1014c817653db92bcd8024ff1935b6be
+ ref: 9b228148f554f0ab6d1a5fb3bfeed81ce48419a8
unpetrify-ref:
build-depends:
- json-c
@@ -178,7 +178,7 @@ chunks:
- name: rpcd
morph: strata/cpe-wrt/rpcd.morph
repo: upstream:openwrt/rpcd
- ref: 805e8ce8918237d93baafa53413c5c4ef0380504
+ ref: 3d655417ab44d93aad56a6d4a668daf24b127b84
unpetrify-ref:
build-depends:
- json-c
diff --git a/strata/cpe-wrt/netifd.morph b/strata/cpe-wrt/netifd.morph
index 30092ea0..2a0336fa 100644
--- a/strata/cpe-wrt/netifd.morph
+++ b/strata/cpe-wrt/netifd.morph
@@ -1,13 +1,6 @@
name: netifd
kind: chunk
-pre-configure-commands:
-- sed -i "s/-Werror//" CMakeLists.txt
-- sed -i "s/netifd\s\${LIBS}/netifd \${LIBS} \${LIBNL_LIBRARIES} \${JSONC_LIBARIES}/" CMakeLists.txt
-- sed -i "s/#include\s\"config.h\"/#include \"config.h\"\n#include \"json-c\/bits.h\"/" handler.h
-- sed -i "s/#include <json/#include <json-c/" handler.c handler.h
-- sed -i "s/SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS \"\")/SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS \"\")\nINCLUDE(FindPkgConfig)\nPKG_CHECK_MODULES(JSONC json-c)\nIF(JSONC_FOUND)\n ADD_DEFINITIONS(-DJSONC)\n INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})\nENDIF()\n\nPKG_CHECK_MODULES(LIBNL libnl-3.0)\nINCLUDE_DIRECTORIES(\${LIBNL_INCLUDE_DIRS})\n/" CMakeLists.txt
-
configure-commands:
- cmake -DCMAKE_INSTALL_PREFIX=$PREFIX -DLIBNL_LIBS=-lnl-tiny -DLIBNL_INCLUDE_DIRS=/usr/include/libnl-tiny
diff --git a/strata/cpe-wrt/procd.morph b/strata/cpe-wrt/procd.morph
index fc0fcabe..bed96223 100644
--- a/strata/cpe-wrt/procd.morph
+++ b/strata/cpe-wrt/procd.morph
@@ -3,7 +3,6 @@ kind: chunk
pre-configure-commands:
- sed -i "s/-Werror//" CMakeLists.txt
-- sed -i "s/#include <json>/#include <json-c>/" service/validate.c plug/hotplug.c
build-commands:
- cmake -DCMAKE_INSTALL_PREFIX=/
diff --git a/strata/cpe-wrt/rpcd.morph b/strata/cpe-wrt/rpcd.morph
index 999f27ec..c6d48461 100644
--- a/strata/cpe-wrt/rpcd.morph
+++ b/strata/cpe-wrt/rpcd.morph
@@ -1,9 +1,6 @@
name: rpcd
kind: chunk
-pre-configure-commands:
-- sed -i "s/json\/json.h/json-c\/json.h/" include/rpcd/plugin.h
-
configure-commands:
- cmake -DCMAKE_INSTALL_PREFIX=$PREFIX